Excel: Počet unikátních buněk ve filtru

Potřebujete spočítat počet unikátních buněk ve sloupci tabulky, u které byl použit filtr,  ale neznáte kouzelnou formulku, která by vám vrátila správný výsledek?

Tak tady je:

=SUMA(KDYŽ(ČETNOSTI(KDYŽ(SUBTOTAL(3;POSUN(A2:A11;ŘÁDEK(A2:A11)-ŘÁDEK(A2);0;1));POZVYHLEDAT("~"&A2:A11;A2:A11&"";0));ŘÁDEK(A2:A11)-ŘÁDEK(A2)+1);1))

Důležité:

  • Jedná se o maticový vzorec, takže jej musíte vložit pomocí CTRL+SHIFT+ENTER.
  • Vzorec spočítá počet unikátních buněk v oblasti A2:A11. Oblast si musíte upravit podle své potřeby.

Pokud převádíte vzorce v Excelu z jednoho jazyka do druhého, tak se vám může hodit Slovníček funkcí v Excelu 2010.


Chcete mi něco říct? Tak mi to řekněte.